Follow

iOS: Is the Ki Edition compatible with my device?

Never Alone: Ki Edition is compatible with the following iPhone, iPad and iPod Touch models running iOS 8 or later. You can check your device here https://support.apple.com/en-kw/HT201471 

iPhone

  • iPhone 7 and 7 Plus
  • iPhone SE
  • iPhone 6s and 6s Plus
  • iPhone 6 and 6 Plus
  • iPhone 5s

iPad

  • iPad (5th Generation)
  • 9.7" iPad Pro
  • 12.9" iPad Pro
  • iPad Air 2
  • iPad Air
  • iPad Mini 4
  • iPad Mini 3
  • iPad Mini 2

iPod Touch

  • iPod Touch (6th generation)

If you are unsure what model device you have, you may find these Apple Support pages for iPhone, iPad and iPod Touch helpful.

0 Comments

Please sign in to leave a comment.
Powered by Zendesk